xsd2Code does not show on the right click Menu

Mar 22, 2011 at 4:46 PM

Since I install the new version of xsd2Code 3.4, I cannot have the right click menu with this option anymore.  I have read all your discussions about it and tried all of the solutions and it still now show.

I am using Windows 7 64bits and VS2010 Sp1.

Thank you for your help.

Mar 27, 2011 at 12:34 AM

Hi, I posted a workaround here : http://xsd2code.codeplex.com/discussions/248964

Mar 31, 2011 at 5:59 PM

I've tried this and when I start VS2010(SP1) I crash telling there has been an internal error, I had to remove the Add-ins...

Mar 31, 2011 at 9:00 PM

really wanted to use, but still no joy with VS 2010 SP1. Fresh install, didnt work. Found this thread (and your referenced one with the patch DLL), still no luck. It doesnt show as an Add-In at all, so i cant use the context menu note someone else posted either.


Apr 27, 2011 at 8:31 AM

I'm in the same situation: I installed it, replaced the DLL, but it still doesn't show up as an add-in. Has anyone found another workaround?

Apr 27, 2011 at 3:01 PM

This solution has worked for several people (this is not my solution, I'm plagiarizing)

Go to Menu Tools/Customize/Commands, Select "Context Menu" et move to "Project and solution Context Menu | Items".

Now Click on "Add Command", select AddIns, and "Run Xsd2Code generation".

OK, Close : The context menu is back !!